Fightnite Matchmaking Issues in the EU Matchmaking Region

Incident Report for EL Games

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 15:00 CET

Monitoring

We have fixed an issue preventing some players from matchmaking when using the EU region as matchmaking region.

Thanks for your patience!
Posted Dec 04, 2025 - 18:31 CET
This incident affected: Fightnite (Matchmaking, Game Services).