Game updates have been deployed. Thank you for your support while we worked to fix these issues.
Posted May 16, 2025 - 21:48 CEST
Update
ELGame Anti-Cheat Update (Hotfix) v.1.5.0 has been deployed. We are currently working to deploy the game updates to apply the anti-cheat hotfix.
Posted May 16, 2025 - 21:37 CEST
In progress
We are currently working to deploy the ELGame Anti-Cheat Hotfix v.1.5.0. We will provide an update once the update has been deployed.
Posted May 16, 2025 - 21:32 CEST
Scheduled
Within the next 15 - 30 minutes, we will deploy an update of ELGame Anti-Cheat to fully resolve the issues which we resolved with our anti-cheat. We will provide an update once update has been deployed. An update for Fightnite & Rider League will be also deployed to apply the hotfix of ELGame Anti-Cheat (v.1.5.0).
Posted May 16, 2025 - 21:27 CEST
This scheduled maintenance affected: ELGame Anti-Cheat.