Network Issues (Resurfaced)

Incident Report for EL Games

Resolved

We've fixed these issues. Thank you for your support and for your patience!
Posted May 17, 2025 - 10:21 CEST

Investigating

The network issues have been resurfaced and we're actively working with our provider to resolve these issues.
Posted May 17, 2025 - 10:00 CEST
This incident affected: EL Online Services (Login, Matchmaking, Lobbys, EL-Account-Services: Authentication | Party Services & Friend Lists), Rider League (Login, Matchmaking), Fall Dudes (Login / Matchmaking, Parties, Friends, and Messaging, Item Shop & Game Services), Fightnite (Login, Matchmaking, Game-Services), and ELGame Anti-Cheat.