EOS Matchmaking services may return a 503 Error

Incident Report for EL Games

Resolved

This incident has been resolved.
Posted May 12, 2025 - 21:46 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2025 - 18:20 CEST

Identified

We're able to reproduce the issue on our end. The backend may also return a 500.
We're deploying a fix that will cause a temporary outage of the entire EOS matchmaking services.
Posted May 12, 2025 - 15:24 CEST

Investigating

We are investigating an issues with EOS (EL Online Services) matchmaking.
Posted May 12, 2025 - 15:00 CEST
This incident affected: EL Online Services (Login, Matchmaking, Lobbys).