EL Games Store Service Disruption

Incident Report for EL Games

Resolved

EL Games Store Issues are now fully resolved. We are continuing to monitor for any further disruptions and we appreciate your patience while we worked through this.
Posted Jul 20, 2025 - 12:07 CEST

Identified

The issue has been identified and we are working on a fix now. EL Games Web Store and the EL Games Launcher Store is only impacted, the mobile Shop will remain online and unimpacted.
Posted Jul 20, 2025 - 11:30 CEST

Investigating

We are currently investigating an issue where the EL Games Store may appear empty or may fail to load. We will provide an update once we have more info.
Posted Jul 20, 2025 - 11:07 CEST
This incident affected: zAI / EL Games Store.