The game updates have been deployed and our anti-cheat has been integraded successfully in our games.
Posted May 14, 2025 - 18:21 CEST
Update
Anti-cheat update has been deployed. We are working to deploy the game updates now.
Posted May 14, 2025 - 18:00 CEST
Investigating
Our new anti-cheat, ELGame Anti-Cheat, is currently under maintenance for update v.1.0.0. We will deploy also a game update for Fightnite, Rider League, and Fall Dudes. The ELGame Anti-Cheat servers are now offline while we work to deploy the update. Game updates will be deployed once we completed the anti-cheat update.
Posted May 14, 2025 - 17:40 CEST
This incident affected: Rider League (Login, Matchmaking, Item Shop, Text- & Voice-Chat, Custom Matchmaking / Private Matchmaking), Fall Dudes (Login / Matchmaking, Parties, Friends, and Messaging, Item Shop & Game Services), Fightnite (Login, Matchmaking, Game Services, Item Shop, Voice Chat), and ELGame Anti-Cheat.