Investigating an issue,

Incident Report for EL Games

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 11:50 CEST

Update

We are continuing to work on resolving an issue affecting login and matchmaking services in Fightnite.
Posted Mar 30, 2026 - 11:03 CEST

Investigating

We‘re investigating issues affecting the listed services.
Posted Mar 30, 2026 - 11:01 CEST
This incident affected: Fightnite (Login, Matchmaking, Game Services).