Performance issues have been fixed and Rider League is now completely back online. We may release a hotfix update within the next days, but this is not completely confirmed.
Posted May 16, 2025 - 20:07 CEST
Monitoring
Rider League is back online, time to play while we are working to fix some performance issues. We'll provide an update once performance issues have been fixed.
Posted May 16, 2025 - 19:38 CEST
Update
To resolve these issues, we are shutting down the following Rider League services: login, matchmaking, item shop, and voice chat. We will provide an update once the services are back online.
Posted May 16, 2025 - 18:07 CEST
Investigating
We're aware that players in Rider League may be experiencing issues with matchmaking or general connectivity. We're actively investigating these issues and will provide an update once this is resolved.
Posted May 16, 2025 - 17:32 CEST
This incident affected: Rider League (Login, Matchmaking, Item Shop, Text- & Voice-Chat, Custom Matchmaking / Private Matchmaking).