Fightnite Creative - Matchmaking Issues in Europe for Creative Maps

Incident Report for EL Games

Resolved

Matchmaking services have been restored. Thank you for your patience while we resolved the issue.
Posted Jul 26, 2025 - 22:51 CEST

Investigating

Some players in the Europe region may be seeing matchmaking errors when accessing their Maps in Fightnite Creative.

We're working to restore matchmaking stability and will provide an update as soon as the issue is resolved, or when more information is available.
Posted Jul 26, 2025 - 19:08 CEST
This incident affected: Fightnite (Matchmaking).