Network Issues

Incident Report for EL Games

Resolved

Internal Network Issues have been resolved.
Posted May 07, 2025 - 18:57 CEST

Investigating

The network issues have been resurfaced. Login and matchmaking in Fightnite is currently degraded. We will provide an update once we have more info.
Posted May 07, 2025 - 18:20 CEST
This incident affected: Fightnite (Login, Matchmaking).