The issue has been identified. We are continuing to investigate this issue.
Posted Mar 12, 2025 - 21:46 CET
Investigating
We're investigating intermittent EOS voice connection issues affecting a subset of users in the Middle East region. We're working to resolve this and will provide another update when we have more info or once the issue is resolved.
Posted Mar 12, 2025 - 17:24 CET
This incident affects: EL Online Services (Login, Matchmaking, Lobbys, EL-Account-Services: Authentication | Party Services & Friend Lists).