ELGame Anti-Cheat: Issues with Reporting other Players (Resurfaced)

Incident Report for EL Games

Resolved

The ELGame Anti-Cheat Hotfix (v.1.5.0) resolved this issue. Thank you for playing and for your support.
Posted May 16, 2025 - 22:01 CEST

Update

The ELGame Anti-Cheat Hotfix (v.1.5.0) resolved this issue. Thank you for playing and for your support.
Posted May 16, 2025 - 22:00 CEST

Monitoring

We've fixed this issue and are monitoring our services.
Posted May 16, 2025 - 21:19 CEST

Investigating

The issues with player reports in ELGame Anti-Cheat have been resurfaced. We are currently investigating.
Posted May 16, 2025 - 20:12 CEST
This incident affected: ELGame Anti-Cheat.